Este plugin no se ha probado con las últimas 3 versiones mayores de WordPress. Puede que ya no tenga soporte ni lo mantenga nadie, o puede que tenga problemas de compatibilidad cuando se usa con las versiones más recientes de WordPress.

Multisite Widgets Context

Descripción

A WordPress Multisite Plugin that runs a Widget in a context of another site that belongs to the network

Cómo funciona

On every Widget, this plugin adds a select menu that you can choose on which site context you will execute the widget.
It also has a option to pull the widget data from target site, you can check this option if you want to populate the data of widget that depends of the context site, with content from the target site. See Screenshots to understand better.

Contribute

You can contribute to the source code in our GitHub page.

Capturas

  • A Recent Posts Widget configured to execute on another site context.

  • A Nav Menu Widget with select populated with data from target site due to checked checkbox

Instalación

To install just follow the installation steps of most WordPress plugin’s:

e.g.

  1. Download the file multisite-widgets-context.zip;
  2. Unzip the file on your computer;
  3. Upload folder multisite-widgets-context, you just unzip to /wp-content/plugins/ directory;
  4. Activate the plugin on the Plugins menu in WordPress;
  5. Be happy.

THIS PLUGIN ONLY WORKS WITH MULTISITE

Preguntas frecuentes

Installation Instructions

To install just follow the installation steps of most WordPress plugin’s:

e.g.

  1. Download the file multisite-widgets-context.zip;
  2. Unzip the file on your computer;
  3. Upload folder multisite-widgets-context, you just unzip to /wp-content/plugins/ directory;
  4. Activate the plugin on the Plugins menu in WordPress;
  5. Be happy.

THIS PLUGIN ONLY WORKS WITH MULTISITE

Can I use this plugins without multisite

No, It does’t make sense to use this plugins without multisite.

I’m trying to run a shortcode in a context of another site and it’s not working.

As switch_to_blog does not switch plugins or theme, you need the code for shortcode running on the site that you are EXECUTING THE WIDGET. If the shortcode is provided by a plugin, just activate the plugin on the site which you want to run the widget.

Reseñas

12 de diciembre de 2016
I’ve spent hours looking for a plugin to do this and finally came across this. You have no idea how much this is appreciated. And to think that such a useful plugin is free… wow! I hope you continue maintaining this… some lives now depend on it. 😀 Thanks again!
3 de septiembre de 2016
Great plugin for non realised multisite functionality. Thank you Nicholas!
3 de septiembre de 2016
In my case I find this plugin is essential in a wordpress multisite environment.
3 de septiembre de 2016
I installed and it worked! No muss, no fuss. All the other similar plugins I found are years old. Hopefully, this will be looked after and upgraded regularly. Brilliant!
Leer todas las 12 reseñas

Colaboradores y desarrolladores

Este software es de código abierto. Las siguientes personas han contribuido a este plugin.

Colaboradores

Traduce “Multisite Widgets Context” a tu idioma.

¿Interesado en el desarrollo?

Revisa el código, echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

1.1.2

  • Fixing a bug where a PHP Fatal error could happen on the append_current_site_context() method.

1.1.1

  • Fixing a bug where the selected site context wasn’t being persisted in some edge cases

1.1.0

  • WordPress 4.5 Compatibility
  • Code Refactoring to better meet WordPress standards
  • Security enhancements: escaping and sanitization
  • Performance Improvements: Caching get_blog_ids method

1.0.3

  • Fixed a bug when a new widget is added to a sidebar and the current site isn’t checked by default
  • WordPress 4.3 compatibility