Conekta Payment Gateway

Descripción

Características recientes de esta version :

  • Usa Conekta.js – No requiere conformidad de temas PCI (Requiere certificado SSL)
  • Tarjeta de credito y debito implementado
  • Pagos de tarjeta implementado
  • Capacidad de hacer pruebas
  • Manejo de estatus automático para las ordenes
  • Notificaciones de correo en compra satisfactoria

Capturas

  • En su administrador de Woocommerce en settings -> checkout, usted podrá necesitara agregar las llaves del API desde Conekta.com
  • Tambien, usted necesitara configurar los webhooks correctamente en su cuenta de conekta agregando http://tusitio.com/wc-api/WC_Conekta_Cash_Gateway asi que la orden cambia dinamicamente
  • Una vez que el usuario pague con la referencia, el estado de la orden en el panel de administración de tu Woocommerce va a cambiar automáticamente. /assets/screenshot-2.png

Instalación

Por favor nota que la versión 3.0.8 requiere de WooCommerce 3.x.
Puedes descargar una versión más antigua aquí.
Asegúrate de que tienes por lo menos la versión 7.4 de PHP, ya que la biblioteca PHP de Conekta requiere de esa versión.

Automático

Ingresa a tu escritorio de WordPress, navega al menú de plugins y haz click en ‘Añadir Nuevo’, en la barra de búsqueda escribe “Conekta Payment Gateway” y haz click en ‘Buscar Plugins’. Una vez que hayas encontrado nuestro plugin, puedes ver los detalles sobre el, y puedes instalarlo con solo dar click en ‘Instalar ahora’.

Manual

  • Sube el zip del plugin en Plugins, Agrégalo y da clic en “Instalar ahora”
  • Una vez instalado, activa el plugin
  • Agrega tus api keys en Woocommerce setings->checkout desde tu cuenta de Conekta (admin.conekta.com) en https://admin.conekta.io#developers.keys
  • Para manejar ordenes para pagos sin conexión el estatus cambia dinamicamente, usted necesitara agregar la siguiente url en su cuenta de Conekta http://tusitio.com/wc-api/WC_Conekta_Cash_Gateway

Remplazar la url de tusitio.com con tu nombre de dominio

Reseñas

18 de enero de 2021
Su pasarela de pagos no tiene compatibilidad con el plugin Deposits de Woocomerce, que funciona para que tus clientes realicen compras con un anticipo. Me contacte al soporte técnico pero no me ofrecieron ninguna solución.
11 de julio de 2019
1) NO funcionan los cupones, 2) el sistema NO actualiza estatus de pagos en OXXO y SPEI, 3) NO hay manera de definir vigencias para cuentas CLABE al momento de recibir pagos de SPEI, 4) NO despliega bien la información en los correos ¿sigo? Es una lástima que la compañía que debería de dar el mejor servicio para OXXO Pay simple y sencillamente no está a la altura... tienen más de un año sin actualizar su plugin y estuve MESES en llamadas con ellos y simplemente no hay para cuando arreglen estos temas y den un soporte medianamente decente a sus usuarios. De momento ¡aléjense de este plugin!
29 de enero de 2018
Soy técnico pero creo que cualquiera pudiera instalar este plugin. Fue muy fácil y esta funcionando muy bien hasta ahorita. Lo uso para todos los pagos en mi pagina a meses, y en general para la mayoría de los pagos con tarjeta. También me ha gustado el admin de conekta para organizar los movimientos. Recomiendo el plugin.
Leer todas las 5 reseñas

Colaboradores y desarrolladores

Este software es de código abierto. Las siguientes personas han contribuido a este plugin.

Colaboradores

Traduce "Conekta Payment Gateway" a tu idioma.

¿Interesado en el desarrollo?

Revisa el código, echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

3.0.8

  • Se corrigió el problema con la cantidad -1

3.0.7

  • Se corrigió el problema con la cantidad -1
  • Se corrigió el problema con la referencia al pago en Oxxo.
  • Se corrige la cantidad en la líneas de descuento.

3.0.5

  • Se actualizaron las imágenes de Conekta Payments.

3.0.4

  • Se corrigió el error de token que ya fue utilizado.

3.0.3

  • Se actualizó la biblioteca PHP, ahora es compatible con PHP 7+

3.0.2

  • Fix: Información de pedido en plantillas de correo electrónico
  • Feature: Instrucciones y descripción personalizadas para el pago de Oxxo y Spei

3.0.1

  • Fix: Arregla cuestiones de librería

3.0.0

  • Changed: Acceda correctamente a las propiedades del pedido (Soporte WooCommerce 3.x)

2.0.14

  • Style: Corrección de errores tipográficos para correo electrónico

2.0.13

  • Nombra el nombre de el beneficiario de la cuenta de SPEI en la sección de ingreso en el administrador del plugin [nueva característica]
  • Nuevas validaciones de verificación de marketplace

2.0.12

  • Error corregido en ajuste de redondeo para valores no enteros
  • Enviar version de plugin en el tag de linea de producto

2.0.11

  • Errores corregidos de token_id faltante

2.0.10

  • Errores corregidos de meses sin intereses

2.0.9

Error corregido en linea de impuestos vacía en descripción

2.0.8

Cambiar nombre de traducción dentro de comentario

2.0.7

Error corregido en SKU menor a 0 caracteres

2.0.6

Corregir envío para tarjeta y spei

2.0.5

  • Error corregido para validaciones de envío en productos virtuales
  • Error corregido en redondeo para centavos no enteros
  • Se agrego fecha de expiración para oxxo pay
  • Error corregido en webhooks para ordenes pagadas

2.0.0

  • Impuestos agregados
  • Descuentos agregados
  • Envio agregado
  • Ordenes agregadas
  • Oxxo Pay
  • Error corregido en webhooks para ordenes pagadas( antes cargos pagados )
  • Se removió Banorte

0.3.0

  • Parametros adicionales agregados para una mejora mas robusta del servicio antifraude para pagos con tarjeta

0.2.0

  • Se agrego la opción para diferentes pagos para 3 6 y 12 meses
  • Habilitar y desactivar diferentes pagos del administrador

0.1.1

  • Pagos offline
  • Código de barras enviado en correo y desplegado para confirmación de pagina
  • Estatus de la orden cambia dinamicamente una vez que el webhook es agregado a Conekta.com

0.1.0

  • Pagos en linea
  • Capacidad de hacer pruebas
  • Opción para guardar el perfil del cliente
  • Validación de tarjetas del servidor de Conekta usted no tiene que tener PCI
  • Validación de cliente para tarjetas de crédito