Este plugin no se ha probado con las últimas 3 versiones mayores de WordPress. Puede que ya no tenga soporte ni lo mantenga nadie, o puede que tenga problemas de compatibilidad cuando se usa con las versiones más recientes de WordPress.

Admin Footer Version (rebranded)

Descripción

Muestra la versión renombrada en el pie de página de administración, (escritorio) cuando se activa, o automáticamente, si está en el directorio mu-plugins.

Este plugin de WordPress expande, asegura y mejora el código núcleo en /wp-admin/includes/update.php

El desarrollo de este plugin tiene lugar en GitHub y Travis CI. Compatible con GlotPress Translations.

Aprobado en el directorio de plugins el 25/12/2017

este plugin utiliza Semantic Versioning MAJOR.MINOR.PATCH

El “sistema de alerta” de PHP y SQL de este plugin, compatible con las especificaciones de Serve Happy / Site Health, se basa (en términos generales) en el bien conocido método de semáforo en rojo, naranja y verde, para que cualquier tipo de usuario pueda identificar inmediatamente, a través de una advertencia “visual de color”, las notificaciones necesarias, incluso sin tener preparación técnica específica.

El propósito final de este plugin “conceptual” es demostrar que es posible, con una simple recodificación, y una buena idea, estandarizar, uniformar, mejorar y recalificar algunos aspectos de WordPress que son dejados en el olvido.

Expandir

Necesario

  • Muestra versión (renombrada) en el área actualizada de pie de página de la administración.
  • Escritorio de mensajes centralizado para todas las instalaciones declaradas.
  • Desarrollos y despliegues centralizados, para todas las instalaciones declaradas.
  • El mismo código funcionará con todas las versiones declaradas de WP.
  • El mismo código funcionará con todas las versiones declaradas de PHP.
  • El mismo código va a trabajar con todas las versiones de SQL
  • Mismo trabajo en código desde WP 2.3+ a 5.1+ ~ 5.2-alpha
  • Compatible con lanzamientos individuales / multiusuario (MU) / Multisitio (MS)
  • Compatible con el directorio mu-plugins.
  • Trabaja con el directorio mu-plugins.
  • Listo para la famosa instalación en 5 minutos.
  • Trabaja con una configuración de instalación de primeros pasos.
  • NUEVO – Salud del sitio / Sirve feliz (presupuesto) obediente.
  • NEW – System Overview of PHP / MySQL / MariaDB version used.
  • NUEVO – muestra la información general del sistema en el área de texto del pie de página de la administración.
  • NUEVO – La visión general del sistema muestra las versiones obsoletas de PHP.
  • NUEVO – La visión general del sistema muestra las versiones obsoletas de SQL.
  • FUTURO – vista general del uso de recursos en la base de datos. (en desarrollo).
  • FUTURO – vista general del uso de recursos en la memoria (en desarrollo).
  • FUTURO – Información general en la barra de administración / barra de herramientas (en desarrollo).
  • FUTURO – Recomendaciones sobre la información general (en desarrollo).
  • FUTURO – Recomendaciones en estilo Hello Dolly (en desarrollo).
  • FUTURO – Ajustes del panel de control de la información general del sistema (en desarrollo).

Mejorar

Incluye

  • Mensajes visuales a color para: desarrollo, mejora, más reciente, anterior.
  • Mensajes visuales de colores: obsoleto, aceptable, soportado, vigente.
  • Mensajes con colores visuales para: legado, más viejo, viejo, estado de WordPress.
  • Mensajes visuales de colores para: lento, rápido, estado de PHP y SQL.
  • Mensajes visuales con colores para: uso de base de datos alto, medio y bajo.
  • Mensajes visuales con colores para: uso de memoria alto, medio y bajo.
  • Introduce concepto de color negro azul verde no incluido en el núcleo.
  • Introduce el concepto de la versión anterior no incluido en el núcleo.
  • Introduce el concepto del desarrollo anterior no incluido en el núcleo.
  • El concepto de la versión anterior es para usuarios de WP 4.9+
  • El concepto del desarrollo anterior es para desarrolladores de WP 4.9+
  • Se revisan los requerimientos de PHP / SQL /WP antes de la activación del plugin.
  • Compatibilidad con traducciones de GlotPress.
  • Los archivos de traducción .mo son incluidos en el paquete distro.
  • Carga automática de los archivos de traducción incluidos al activar.
  • Los archivos de traducción trabajan con instalaciones en línea y fuera de línea.

Seguro

Proporciona

  • La posibilidad de visualizar la versión se desactiva para todos los usuarios excepto administradores.
  • Se eliminó la visualización de la versión para todos los usuarios excepto para los administradores.
  • Solo los perfiles que manejan opciones o el núcleo pueden actualizar WordPress.
  • Se corrigieron los perfiles de usuario faltantes para las actualizaciones de núcleo.
  • Se corrigieron los perfiles de usuario faltantes para las actualizaciones de desarrollo.
  • Secured the user roles with capability can update WordPress.
  • Only manage_options capability roles (WP 2.3+ to 2.9+).
  • Only update_core capability roles (WP 3.0+ to 5.1+ ~ 5.2-alpha).
  • System Overview obfuscated for non manage_options capability.
  • System Overview obfuscated for non update_core capability.

Tabla de clasificaciones

WordPress

  • Legacy version 2.3+ to 2.6+ – red color highlighted
  • Versión más vieja de 2.7+ a 2.9+ – destacada en color rojo
  • Versión más vieja de 3.0+ a 3.6+ – destacada en color rojo
  • Supported version 3.7+ to 4.8+ – orange color highlighted
  • Latest previous version 4.9+ – blue color highlighted
  • Última versión disponible 5.0+ – destacada en color negro
  • Latest available version 5.1+ – green color highlighted
  • Versión de desarrollo 5.2-alfa – destacada en color naranja

PHP

  • 5.2+ slow – deprecated version red color highlighted
  • 5.3+ slow – deprecated version red color highlighted
  • 5.4+ slow – deprecated version red color highlighted
  • 5.5+ slow – deprecated version red color highlighted
  • 5.6+ slow – acceptable version orange color highlighted
  • 7.0+ fast – end-of-life version red color highlighted
  • 7.1+ fast – supported version black color highlighted
  • 7.2+ fast – previous version blue color highlighted
  • 7.3+ fast – current version green color highlighted
  • 7.4+ fast – development version orange color highlighted

(Ciclo end-of-life de PHP)

MySQL

  • 5.0+ oldest version red color highlighted — MyISAM
  • 5.1+ versión vieja resaltada en color rojo — MyISAM
  • 5.5+ versión aceptable resaltada en color naranja — InnoDB
  • 5.6+ previous version blue color highlighted — InnoDB
  • 5.7+ current version green color highlighted — Percona
  • 8.0+ development version orange color highlighted — Percona

MariaDB

  • 5.5+ versión aceptable resaltada en color naranja — XtraDB
  • 10.0+ versión aceptable resaltada en color naranja — XtraDB
  • 10.1+ supported version black color highlighted — InnoDB
  • 10.2+ versión anterior resaltada en color azul — InnoDB
  • 10.3+ versión actual resaltada en color verde — InnoDB
  • 10.4+ versión en desarrollo resaltada en color naranja — InnoDB

Memoria

  • Uso de memoria al 75% – destacado con color rojo
  • Uso de memoria al 50% – destacado con color naranja
  • Uso de memoria al 25% – destacado con color verde

(en desarrollo)

Consejos

Un buen truco es poner este archivo individual admin-footer-version-rebranded.php (no su directorio padre) en el directorio /wp-content/mu-plugins/ directory (créalo si no existe) para que ni siquiera tengas que activarlo, y se cargará por defecto, también, ¡desde el primer paso de la instalación de la configuración de WordPress!

También, para funcionalidad con la traducción, pon todos los archivos de idiomas individuales (por ejemplo (admin-footer-version-rebranded-en_US.mo) que necesites (no su directorio padre) en el directorio e /wp-content/mu-plugins/ (créalo si no existe) y será cargado por defecto ¡desde el primer paso de la configuración de la instalación de WordPress!

Note that mu-plugins functionality is available since WP 2.8+ or greater and is not present in WP 2.7+ or previous.

Acerca de

The code of this plugin is not written with a PHP framework, but manually, with a simple PHP editor compatible UTF-8 without BOM, and Unix LF. To avoid code corruption, do not edit it with WordPress embedded editor, or with any specifications incompatible editor. This author is exonerated from any responsibility or damage (directly or indirectly) caused and due to the use of this bad practice.

súper ligero seguro rápido útil fácil en los recursos del servidor

Sobre mi

Admin Footer Version (rebranded) is developed by Luciano Croce, 13-years “officially” WordPress Plugins & Themes Developer Senior, Co-Author of the plugin Classic Editor, polyglot (based on English, French, Spanish, German, Portuguese, Italian, Ligurian), GTE en_GB & en_CA & en_ZA & LIJ, PTE and translator for Plugins & Themes in more languages, PTE for Italian WordPress.org & Plugins & Themes Directory, Local Manager of Ligurian Language Community for WP LIJ, Validator English (UK) for WordPress.com, book author of TRUE DOS (the dark side of its history from the dark side of its users) Code Tweaker & Bug Hunter, Security Mechanic & WPMU Lover, Freelancer & Volunteer.

este es mi mejor plugin conceptual de todos los tiempos

Traducción

Disponible en 25 langs 4 variantes formales/informales, y otras en convertirse.

Traducido por Luciano Croce en: Australiano, Belga FR, Brasileño, Canadiense EN, Canadiense FR, Catalán, Chileno, Colombiano, Inglés UK, Francés, Alemán, Italiano, Ligur, Neozelandés, Peruano, Portugués, Español, Suizo DE, Venezolano.

Traducido por Dan Caragea en Rumano.

Traducido por Knut Sparhell en Noruego.

¡Todas las contribuciones son apreciadas y acreditadas!

Traductores, para probar cadenas y traducciones parciales use el plugin Force Update Translations.

Expresiones de gratitud

Gracias por las correcciones, sugerencias y aprobación de traducción para

Equipo

  • Català / Catalan – València / Valencia — ca
  • Deutsch (Schweiz) / German (Switzerland) — de_CH
  • Deutsch / German — de_DE
  • English (Australia) — en_AU
  • English (Canada) — en_CA
  • English (UK) — en_GB
  • English (New Zealand) — en_NZ
  • English (South Africa) — en_ZA
  • Español de Argentina / Spanish (Argentina) — es_AR
  • Español de Chile / Spanish (Chile) — es_CL
  • Español de Colombia / Spanish (Colombia) — es_CO
  • Español de Costa Rica / Spanish (Costa Rica) — es_CR
  • Español / Spanish (Spain) — es_ES
  • Español de Guatemala / Spanish (Guatemala) — es_GT
  • Español de México / Spanish (Mexico) — es_MX
  • Español de Perú / Spanish (Peru) — es_PE
  • Español de Venezuela / Spanish (Venezuela) — es_VE
  • Français de Belgique / French (Belgium) — fr_BE
  • Français du Canada / French (Canada) — fr_CA
  • Français / French (France) — fr_FR
  • Nederlands (België) / Dutch (Belgium) — nl_BE
  • Nederlands / Dutch — nl_NL
  • Norsk bokmål / Norwegian (Bokmål) — nb_NO
  • Polski / Polish — pl_PL
  • Português do Brasil / Portuguese (Brazil) — pt_BR
  • Português / Portuguese (Portugal) — pt_PT
  • Română / Romanian — ro_RO
  • Русский / Russian — ru_RU
  • Svenska / Swedish — sv_SE
  • Zenéize / Ligurian (Genoese) — lij

Esta es la lista de equipo que me ha ayudado en las traducciones.

Gente

Esta es la lista de la gente que me ha ayudado en las traducciones.

Agradecimientos

This plugin incorporates a little code portion of the WordPress files update.php and hello.php that is copyrighted by Automattic and released under the terms of GPLv2 or later license. This little code portion was modified and redistributed under the same terms of GPLv2 or later WordPress license, so that could be patched and extended, to meet the necessary requirements for its functions.

Privacidad

Este plugin no recolecta ni almacena ningún dato relacionado con el usuario o información de identificación personal, no utiliza ninguna cookie y no se conecta a sitios web de terceros. Solo usa funcionalidades que están disponibles en cualquier WordPress. Bajo estos términos, no afecta la privacidad de los usuarios de tu sitio web de manera alguna.

RGPD

This plugin does not collect or store any user related data or personally identifying information, but does not do anything to make your site less/more GDPR compliant. I have done my best to ensure that is 100% GDPR compliant, but I can’t guarantee anything. To determine if your site is 100% GDPR compliant, please consult a lawyer.

Capturas

  • Captura de pantalla 1 de 10 -- Seguridad
  • Captura de pantalla 2 de 10 -- PHP & MySQL Resumen Sistema
  • Captura de pantalla 3 de 10 -- Actualizar a la Última Versión
  • Captura de pantalla 4 de 10 -- Ultima Versión

Reseñas

No hay reseñas para este plugin.

Colaboradores y desarrolladores

Este software es de código abierto. Las siguientes personas han contribuido a este plugin.

Colaboradores

"Admin Footer Version (rebranded)" ha sido traducido a 24 idiomas locales. Gracias a los traductores por sus contribuciones.

Traduce "Admin Footer Version (rebranded)" a tu idioma.

¿Interesado en el desarrollo?

Revisa el código, echa un vistazo al repositorio SVN o suscríbete al registro de desarrollo por RSS.

Registro de cambios

Aprobado en el directorio de plugins el 25/12/2017

Los cambios detallados están disponibles en GitHub.

Los registro de cambios completos están disponibles en changelog.txt

Future Version

Fecha de lanzamiento: nel divenire

  • Adds placeholders support — Thx Knut Sparhell
  • Preemptive support for WP 5.3-alpha
  • FIX – Screen readers — removed title attributes
  • NUEVO – Recommendations in Hello Dolly style
  • NUEVO – Recommendations show requirements
  • NUEVO – Adds Overview in Admin Bar / Toolbar
  • NUEVO – Overview show DB / Memory usage
  • NUEVO – Overview show DB / Memory details
  • NUEVO – Overview show obsolete SQL versions
  • NUEVO – System Overview control panel settings

1.1.5

Fecha de lanzamiento: nel divenire

  • Site Health / Serve Happy specs compliant
  • NUEVO – Adds Overview in admin Footer Text
  • NUEVO – Overview show PHP / SQL version used
  • NUEVO – Overview show obsolete PHP versions

1.0.5

Fecha de lanzamiento: 14 de febrero de 2019

  • Special Saint Valentine Edition ❤
  • Compatible with WordPress 5.1 or later
  • Preemptive support for WP 5.2-alpha
  • Work with WordPress 2.3+ to 5.1+ ~ 5.2-alpha
  • Work with MySQL 5.5+ to 5.7+ ~ 8.0 or later
  • Work with MariaDB 5.5+ to 10.3+ ~ 10.4 or later
  • Adds Romanian translation — Thx Dan Caragea
  • Adds Norwegian translation — Thx Knut Sparhell
  • Adds support for WP 2.4-bleeding testing
  • Adds white color support in WP 2.8+ ~ 2.9+
  • Improved translation strings in main file
  • Reduced translation strings in main file
  • NUEVO – Dismiss useless Core Update Nag
  • UPD – Adds translators comments – i18n ~ l10n
  • UPD – Updated included .mo translation files
  • FIX – HTML coding issues in W3C validation
  • FIX – Minor CSS color type issue in WP 2.9+
  • FIX – Minor CSS color type issue in WP 2.8+
  • FIX – Minor issue to work correctly with WP 2.7+
  • FIX – Minor issue to work correctly with WP 2.3+